This repository has been archived on 2025-03-26. You can view files and clone it, but cannot push or open issues or pull requests.
brook/flake.nix
2025-01-03 18:33:59 -05:00

28 lines
590 B
Nix

{
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
flake-parts.url = "github:hercules-ci/flake-parts";
};
outputs = {
flake-parts,
nixpkgs,
self,
...
} @ inputs:
flake-parts.lib.mkFlake {inherit inputs;} {
systems = ["x86_64-linux" "aarch64-linux" "aarch64-darwin" "x86_64-darwin"];
perSystem = {
pkgs,
system,
...
}: {
_module.args.pkgs = import nixpkgs {inherit system;};
devShells.default = pkgs.mkShell {
buildInputs = [pkgs.flutter];
};
};
};
}