nixos/modules/server/ssh.nix
2025-03-25 17:23:36 -04:00

11 lines
266 B
Nix

{
users.users.quadradical.openssh.authorizedKeys.keys = import ../../secrets/keys.nix;
services.openssh = {
enable = true;
settings = {
PasswordAuthentication = false;
AllowUsers = ["quadradical"];
PermitRootLogin = "no";
};
};
}